Error in react native uuid.generate

Hello community. I am developing a project with react native for android tv and I am following the documentation (GitHub - bitmovin/bitmovin-player-react-native: Official React Native bindings for Bitmovin's Mobile Player SDKs.) but when I try to instantiate the player using hooks or using the player object it throws me the following error “TypeError: null is not an object (evaluating ‘Uuid.generate’)”, I tried with different license keys but I did not have a solution and I have not found anything about it. If anyone has had the same error I would appreciate the help. Thank you.
Captura de pantalla de 2022-11-08 17-17-09
Captura de pantalla de 2022-11-08 17-17-44

Hi,
Hm, this is interesting. The Uuid.generate is something we use within our wrapper and is part of react-native:

import { NativeModules } from 'react-native';
const Uuid = NativeModules.UuidModule;
const id = Uuid.generate();

If the react-native environment is correctly setup on your device I wouldn’t expect something like this to happen. Sounds like the Metro bundler is complaining about that, right? At compile time already or during the run-time? If the latter, do you try to build for Android or iOS?

Can you run the example in our RN repo: bitmovin-player-react-native/example at development · bitmovin/bitmovin-player-react-native · GitHub?

It really shouldn’t be necessary, but as a workaround you can specify your own player ID in the config:

const player = usePlayer({
  nativeId: 'my-player',
});

Please note that if you are using the same id again in the app, you get the same native player instance returned. Please see this section in the README for details.

Hello, I tried this solution but it doesn’t work for me either, I still get the same error

This is very strange. Did you try the example project I linked above (https://github.com/bitmovin/bitmovin-player-react-native/tree/development/example) as well?