Make HEVC MP4 codec ID consistent


When encoding to H.265 SDR MP4 with AAC audio the codec ID of the output is “hvc1” (I would consider this the default behaviour).
However, under those two circumstances the encoder deviates from the default behaviour and the codec ID of the output changes to “hev1”:

  • H.265 SDR MP4 output with Dolby Atmos audio track has codec ID “hev1” instead of “hvc1”
  • H.265 SDR MP4 created from Dolby Vision HDR Source (HDR to SDR downconversioin) has codec ID “hev1” instead of “hvc1” (audio not relevant in this case)

Why does this need changing?

Apple recognizes only the “hvc1” codec ID. So any files that use “hev1” codec ID can not be played with native Apple tools like Quicktime. This creates a lot of confusion on end-user side and therefore lots of “encoding is broken” type support requests.

Feature Request

I would expect the encoder to behave consistently and always output H.265 SDR MP4 with the same codec ID. Imho the default codec ID for H.265 SDR MP4 outputs should always be “hvc1” since this works with Mac and PC.

An alternative solution would be to enable setting the codec ID for the encoding manually (explicitly choose between “hev1” or “hvc1”). This is already possible for Dolby Vision encodings with the “trackSampleEntryName” parameter.
This would enable users to effectively work around the currently inconsistent behaviour of the bitmovin-encoder.

Reference support ticket: #13353


Hi Daniel,

Good to read your feedback in our community! Thank you also for the well-formatted request. I see we have also already gathered 5 votes on this :tada:

I discussed it with the team and we are in favour of making hvc1 the default for all cases. It will need further investigation to plan for this so we don’t have a timeline for the change yet.

I’ll make sure to keep everyone updated about progress in this thread.

Thank you and best,

1 Like